Monday, December 01, 2014

PreRender install error


Problem/Error 

C:\_dev\...\prerender\node_modules\prerender\node_modules\phantom\n
ode_modules\dnode\node_modules\weak>node "C:\Program Files\nodejs\node_modules\n
pm\bin\node-gyp-bin\\..\..\node_modules\node-gyp\bin\node-gyp.js" rebuild
Building the projects in this solution one at a time. To enable parallel build,
please add the "/m" switch.
C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.Cpp.Platform.t
argets(64,5): error MSB8020: The build tools for Visual Studio 2010 (Platform T
oolset = 'v100') cannot be found. To build using the v100 build tools, please i
nstall Visual Studio 2010 build tools.  Alternatively, you may upgrade to the c
urrent Visual Studio tools by selecting the Project menu or right-click the sol
ution, and then selecting "Upgrade Solution...". [C:\_dev\hmh\curiousworld\prer
ender\node_modules\prerender\node_modules\phantom\node_modules\dnode\node_modul
es\weak\build\weakref.vcxproj]
gyp ERR! build error

https://github.com/atom/atom/issues/2435

Below is the solution

When I set below path variable resolved it, in the same command prompt
set GYP_MSVS_VERSION=2013